Mobile Version 4 - Updates

PSA Mobile app users,

Please note that the 4.0 upgrade is not a mandatory one.  It has lots of new features that customers have been asking for but is NOT a mandatory upgrade.

If you do not wish to receive this update, please ensure that your Auto-updates settings are turned off on your devices.

In the future, the Mobile Version 4 will be the only supported mobile application, but at the moment both 3.75 and 4.0 are supported.

Thank you,

Stephane McLaughlin

Customer Service Manager

Canam Systems

Comments are closed

PageList

Month List